Dashboard sign in not succeeding

Incident Report for Vouchsafe

Resolved

We’ve resolved this incident - dashboard users should now be able to log in
Posted May 05, 2026 - 11:50 UTC

Investigating

We are currently investigating an issue where when users try to sign into the dashboard, it does not succeed.
Posted May 05, 2026 - 11:40 UTC
This incident affected: Dashboard.