Postcode lookups are failing

Incident Report for Vouchsafe

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 16:57 UTC

Monitoring

Due to an issue in an upstream provider, postcode lookups are currently failing in the smart lookup product with a "fetch failed" message.
Posted Feb 04, 2026 - 16:09 UTC
This incident affected: Management dashboard.